Business Engineering Group | Главная страница Бизнес Инжиниринг Групп | Главная страница Написать письмо Написать письмо Карта сервера Карта сайта
Бизнес Инжиниринг Групп
ЧаВо Форум Контакты Прайс
ЧаВо
Форум
Контакты
Прайс
О фирме
Консалтинг
Обучение
Инструменты
Клиенты
е-Государство
Теория
Публикации
Ответы на часто задаваемые вопросы

Общие сведения по установке

Задайте нам вопрос

Имя:

Компания:

Телефон:

E-mail:

Вопрос:
Введите число на рисунке:
Главная | Поддержка | Ответы на часто задаваемые вопросы

Ответы на часто задаваемые вопросы

Ответы на часто задаваемые вопросы по версиям программы "БИГ-Мастер" 1.2, 2.1, 2.4, 3.1, 4.3, 5.1, 10.2

I.   Общие вопросы

Вопрос

После инсталляции программы в репозитарии нет или находятся не все референтные модели.

Ответ

Установка референтных моделей и библиотечных классификаторов производится после установки программы "ОРГ-Мастер ПРОФИ". Для их установки в программе предусмотрен специальный мастер, запустить его можно командой "Сервис" – "Установка моделей" главного меню программы. Для установки всех референтных моделей и библиотечных классификаторов на запрос мастера "Выберите файл моделей для установки. Вставьте диск с моделями" укажите файл models.big, расположенный в каталоге MODELS установочного диска. Затем нажимайте кнопку "Далее" и оставляйте настройки, установленные по умолчанию. Подробнее см. "Руководство пользователя" раздел "Сервисные функции", глава "Установка моделей".

Вопрос

После инсталляции программы в репозитарии отсутствуют библиотечные классификаторы.

Ответ

Установка референтных моделей и библиотечных классификаторов производится после установки программы "ОРГ-Мастер ПРОФИ". Порядок установки библиотечных классификаторов см. в ответе на вопрос "После инсталляции программы в репозитарии нет или находятся не все референтные модели".

Вопрос

Какая версия Windows годится для работы с "ОРГ-Мастер Профи"?

Ответ

На момент выхода программы – Windows 98, ME, NT 4.0 (с Service Pack не ниже 3), 2000, XP.

Вопрос

Недавно приобрели у вас программу "ОРГ-Мастер ПРОФИ". При установке программы под Windows XP появляется сообщение о невозможности установить Hardlock (драйвер ключа).

Ответ

Для установки программы "ОРГ-Мастер ПРОФИ" под Windows XP необходимо:

1. Запустить установку программы (файл setup.exe каталога SETUP установочного диска). В диалоге при установке программы необходимо указать "Не устанавливать драйвер".

2. После завершения установки программы можно перейти к установке драйверов ключа. Для этого на локальных рабочих местах необходимо запустить утилиту hldrv32.exe. На сервере необходимо сначала установить менеджер лицензий, запустив утилиту hlsw32.exe; затем установить драйвер ключа, запустив утилиту hldrv32.exe.

3. Перезагрузить все ПК, на которых была проведена установка ПМК "ОРГ-Мастер Профи".

Утилиты hlsw32.exe и hldrv32.exe находятся на установочном диске по адресу ..\UTILS\HARDLOCK. В настоящее время поставляются утилиты hlsw32.exe с датой изготовления 25.07.2001 и hldrv32.exe с датой изготовления 18.02.2004. Если дата изготовления утилиты hldrv32.exe более ранняя, то необходимо ее обновить, скачав обновленную утилиту с одного из сайтов:

http://www.aladdin.ru/downloads/hardlock/hardlockdownloads.php

http://www.aladdin.de/produkte/hardlock/ hardlock_support_setup.html

или отправив запрос на адрес службы технической поддержки support@big.spb.ru для получения утилиты по электронной почте.

Это решение проблемы подходит и для программы "БИГ-Мастер" версий 1.3, 2.5, 4.4, 7.2, 10.3.

Вопрос

Купленная у Вас в 2003 году программа "ОРГ-Мастер ПРОФИ" работала под Windows 98, а когда на фирме перешли на Windows XP, то при инсталяции вышло сообщение о необходимости обновления программы. Подскажите, что делать?

Ответ

Выводимое сообщение относится не к самой программе, а к драйверу ключа защиты. Для корректной установки устанавливайте программу в режиме "не устанавливать драйвер", после чего скачайте с одного из сайтов:

http://www.aladdin.ru/downloads/hardlock/hardlockdownloads.php

http://www.aladdin.de/produkte/hardlock/ hardlock_support_setup.html

новую версию драйвера и установите ее. Также получить обновленный драйвер ключа можно, отправив запрос на адрес службы технической поддержки: support@big.spb.ru.

Это решение проблемы подходит и для программы "БИГ-Мастер" версий 1.3, 2.5, 4.4, 7.2, 10.3.

Вопрос

Где на поставочном диске находится инструкция по установке программы?

Ответ

Инструкция по установке программы находится в корневом каталоге поставочного диска (файл "Установка ПМК БИГМастер.rtf" ("Установка ПМК ОРГМастер.rtf ")).

II.   Вопросы по эксплуатации ключей защиты

Вопрос

Можно ли соединять друг с другом разные ключи Hardlock?

Ответ

Да, несколько ключей Hardlock могут быть соединены в цепочку безо всяких дополнительных приспособлений.

Вопрос

А как насчёт ключей других производителей?

Ответ

Ключи Hardlock полностью прозрачны. Их можно включать в цепочку как до, так и после других ключей, при условии, что те также прозрачны.

Вопрос

Можно ли установить рабочую версию программы "ОРГ-Мастер Профи" на ноутбуке, на котором нет порта LPT? Как в этом случае установить ключ защиты?

Ответ

На ноутбуке, на котором нет порта LPT, можно использовать электронный ключ защиты с разъемом для порта USB.

Вопрос

Ключ подключён к компьютеру, но защищённая программа выдаёт ошибку "Ключ защиты не найден".

Ответ

Проверьте конфигурацию LPT порта в BIOS вашего компьютера. Должна быть установлена поддержка двунаправленной работы порта (EPP, ECP, BiDirectional).

Попробуйте переустановить драйвер ключа.

Попробуйте, скачать обновленный драйвер ключа защиты (файл hldrv32.exe или его архивную копию hldrv32.zip):

http://www.aladdin.ru/downloads/hardlock/hardlockdownloads.php

http://www.aladdin.de/produkte/hardlock/ hardlock_support_setup.html

Вопрос

Ключ периодически "пропадает". Если ключ пошевелить рукой, то контакт может восстановиться.

Ответ

На практике встречались две причины, вызывающие такой эффект:

Имеется ненадежный контакт. Такое может возникать при использовании ключа на портах с изношенными разъемами. Рекомендуется замена разъема.

"Мусор" в разъеме ключа. Удалите его.

Вопрос

Не виден ключ на машинах класса Brand Name (Compaq, Dell, …)

Ответ

Такие машины довольно часто имеют нестандартные базовые адреса принтерных портов. Следует либо изменить такой адрес на стандартный (LPT1 – 378h, LPT2 – 278h, LPT3 – 3BCh) через Setup машины, либо установить плату расширения со стандартным принтерным портом.

Вопрос

Когда выключен принтер, подсоединенный к компьютеру через ключ, защищенное приложение не видит ключа. Если принтер включен – все нормально.

Ответ

Причина такого поведения ключа в том, что он получает питание от шин порта. Когда принтер выключен, его входные цепи представляют собой активную нагрузку на шины порта и вызывают "просадку" напряжения на них. Из-за этого ключ не получает необходимой энергии и перестает работать. Возможные решения:

Не выключать принтер;

Переместить ключ на другой порт или на другой компьютер (если ключ сетевой).

Вопрос

Установка VxD-драйвера под Windows NT завершается неудачно.

Ответ

Данная проблема, как правило, возникает на машинах, где при установке Windows NT имели место проблемы (неполная установка, аварийное завершение и т. д. ). Причины пока неизвестны. Проблема обычно исчезает после установки (или переустановки) последней версии Service Pack.

Вопрос

При попытке печатать из защищённой Windows-программы возникают ошибки печати.

Ответ

Причиной ошибок является конфликт между принтером и ключом. Чтобы избежать конфликта между ключом и другими устройствами, подключаемыми к параллельному порту (такими, как принтер), установите драйвер устройства Hardlock. Попробуйте установить обновленный драйвер принтера. Его можно скачать на сайте фирмы-производителя принтера.

III.   Вопросы по работе программы "ОРГ-Мастер Профи"

1. Общие

Вопрос

Не открывается рабочая модель.

Ответ

Сохраните модель в произвольном каталоге вне программы (командой "Модель" - "Отправить" - "В директорию" (см. "Руководство пользователя" раздел "Репозитарий моделей" глава "Работа с моделью")). В результате получится файл модели с расширением b5j. Отправьте полученный файл модели по электронной почте на адрес Службы технической поддержки  support@big.spb.ru. Попытайтесь выйти из программы, заархивировать файл user.$$$ из каталога программы; и полученный архивный файл тоже отправить по электронной почте на адрес Службы технической поддержки. В тексте или в теме этого же письма укажите "не открывается модель".

Вопрос

В модели не открывается ряд классификаторов.

Ответ

Отправьте модель и заархивированный файл user.$$$ из каталога программы по электронной почте на адрес Службы технической поддержки (см. ответ на вопрос "Не открывается рабочая модель"). В тексте этого же письма укажите классификаторы, которые не удалось открыть.

Вопрос

Почему у некоторых классификаторов и проекций иногда блокируется часть операций контекстного меню, и как с этим бороться?

Ответ

Часть операций контекстного меню автоматически блокируется у тех классификаторов и проекций, которые открыты в программе в данный момент. Блокируются те операции, которые запрещено проводить с открытыми (для редактирования) объектами (например, изменение свойств, очистку, удаление и т.д.). Чтобы были доступны все операции контекстного меню, закройте нужный классификатор или нужную проекцию (не забыв сохранить внесенные изменения). Также автоматически блокируется часть операций контекстного меню классификаторов и проекций, если открыта компонента модели, содержащая этот классификатор или проекцию. Например: Если открыта проекция "Функции_Функции(Документы)", то происходит автоматическая блокировка части операций контекстного меню классификаторов "Функции" и "Документы", и проекции "Функции_Функции(Документы)". После закрытия проекции "Функции_Функции(Документы)", все операции контекстных меню классификаторов "Функции" и "Документы" и проекции "Функции_Функции(Документы)" снова будут доступны.

Вопрос

Можно ли модель, созданную в учебной версии, перенести в рабочую версию?

Ответ

Такая возможность существует.

Для проведения импорта:

1. Модель, созданную в учебной версии, предварительно сохраните в каталоге на диске (вне рабочего каталога программы) командой главного меню "Модель" - "Отправить" – "В директорию" (см. "Руководство пользователя" раздел "Репозитарий моделей" глава "Работа с моделью"). В результате получится отдельный файл модели с расширением b5e, который и нужно импортировать в рабочую версию.

2. Затем в рабочей версии программы выполните команду "Модель" - "Создать" - "Из файла". При выборе импортируемого файла в окне файловой системы, в раскрывающемся списке "Тип файлов" выберите строку "Модели учебной версии", и укажите модель учебной версии, предварительно сохраненную в каталоге на диске (см. пункт 1). Подробнее см. "Руководство пользователя" раздел "Репозитарий моделей", глава "Создание модели".

Вопрос

Как отправить модель по E-mail?

Ответ

Воспользуйтесь возможностью сохранить модель в виде отдельного файла с расширением b5j вне каталога программы, и полученный файл отправьте по почте. Подробнее: 1. Сохранить модель в виде отдельного файла в произвольном каталоге, не принадлежащем каталогу программы, можно командой "Модель" - "Отправить" - "В директорию" (см. "Руководство пользователя" раздел "Репозитарий моделей" глава "Работа с моделью"). В результате получится отдельный файл модели с расширением b5j, который и нужно отправить по почте в виде вложения. 2. Пользователю, получившему модель по почте, для установки модели в репозитарии моделей (программы "ОРГ-Мастер Профи") необходимо: a. Сохранить приложенную к письму модель в произвольном каталоге на диске. b. Импортировать сохраненное на диске вложение (см. п.a) в программу "ОРГ-Мастер Профи", выполнив команду "Модель" - "Создать" - "Из файла", (см. "Руководство пользователя" раздел "Репозитарий моделей" глава "Создание модели" создание модели из файла).

Вопрос

Как переименовать классификатор, проекцию, набор проекций, отчет?

Ответ

Откройте свойства нужного классификатора, проекции, набора проекций или отчета, и на закладке "Основные" введите его новое название, затем закройте окно "Свойства", нажав кнопку "ОК". Рассмотрим подробнее, как изменить наименование классификатора: 1. Выберите нужный классификатор. 2. Откройте свойства классификатора командой "Свойства" контекстного меню классификатора. 3. Введите новое название классификатора в строке "Название" на закладке "Основные". 4. Закройте свойства классификатора, нажав кнопку "ОК", расположенную в нижней части окна "Свойства классификатора". 5. Для сохранения в модели нового названия классификатора сохраните модель. Аналогичным образом можно изменить название проекции, набора проекций или отчета.

Вопрос

Как добавить новые классификаторы,  проекции и отчеты?

Ответ

Выполните команду главного меню программы "Классификатор" - "Создать", "Проекция" - "Создать", "Набор проекций" - "Создать" (см. "Руководство пользователя" раздел "Классификаторы" глава "Создание нового классификатора"; раздел "Проекции" главы "Создание простой проекции", "Создание составной проекции"; раздел "Наборы проекций" глава "Создание набора проекций").

2. Классификаторы

Вопрос

Как перемещать элементы классификатора?

Ответ

Для перемещения одного элемента классификатора в пределах экрана перейдите в режим редактирования классификатора "Дерево". Выберите элемент классификатора, который нужно переместить. Удерживая нажатой левую кнопку мыши, перетащите изображение элемента классификатора на ту позицию, в подуровень которой он должен быть помещен. Или удерживая нажатой левую кнопку мыши и клавишу "Ctrl", перетащите изображение элемента классификатора на ту позицию, в уровень которой он должен быть помещен. Если несколько элементов классификатора нужно переместить в подуровень какого-либо элемента классификатора, воспользуйтесь командой панели редактирования классификатора "Переместить помеченные". Пометьте нужные элементы, выберите позицию, в подуровень которой они должны быть перемещены, и нажмите кнопку "Переместить помеченные". Также для перемещения элемента можно воспользоваться командой "Вырезать/Копировать" + "Вставить/Вставить в подуровень".

Вопрос

Как загрузить в классификатор данные из других систем?

Ответ

Сохраните данные из других систем в виде текстового файла. Затем произведите импорт полученного текстового файла в классификатор (см. "Руководство пользователя" раздел "Заполнение классификатора импортом" главы "Заполнение классификатора импортом", "Импорт из текстового файла"). Или (в зависимости от задачи) дополните имеющийся классификатор импортом позиций из текстового файла (см. "Руководство пользователя" раздел "Дополнение классификатора импортом позиций" главы "Дополнение классификатора импортом позиций", "Импорт позиций из текстового файла").

3. Отчеты

Вопрос

Как настроить отступы, шрифты и т.п. в текстовом отчете в окне предварительного просмотра отчетов?

Ответ

Чтобы изменить настройку отступов и шрифтов отчета, измените шаблон автоформатирования, соответствующий отчету. Изменить шаблон отчета можно при просмотре отчета, нажав кнопку главного меню окна предварительного просмотра отчета "Настроить стили". Кроме того, любой из шаблонов, кроме шаблона, устанавливаемого в отчете по умолчанию, можно изменить на закладке "Шаблоны автоформатирования" окна "Настройки программы" (см. "Руководство пользователя" раздел "Мастера" глава "Окно предварительного просмотра отчетов"; раздел "Сервисные функции" глава "Настройки программы"). Кроме того, на закладке "Шаблоны автоформатирования" можно создать новый шаблон автоформатирования. Обратите внимание, что введенные вами изменения будут применены ко всем отчетам, в которых используется этот шаблон, поэтому изменять шаблон, устанавливаемый по умолчанию, не рекомендуется.

Вопрос

Что делать, если табличный отчет при формировании выдает ошибку?

Ответ

Необходимо проанализировать сообщения об ошибках. Как правило, они имеют вид: Строка (*N_M_K{Поле1,Поле2...ПолеK}) не имеют соответствие в шаблоне. Определите, какому элементу отчета соответствует *N_M_K. Проверьте, все ли поля для этого элемента необходимо выводить в отчет. Часто лишним являются поля CAPTION - подзаголовок элемента отчета и NUMBER. Снимите флажки, отвечающие за вывод лишних полей. Измените шаблон, добавив в него необходимые поля.

4. Процессное описание

Вопрос

Почему в дереве процессов видны не все процессы?

Ответ

В программе предусмотрена возможность задавать состав дерева процессов вручную. Состав дерева процессов задается при помощи расстановки связей в проекции характеристик (проекция, состоящая из классификатора "Функции" и классификатора "Процессы" и подключенная к набору проекций). Чтобы процесс отображался в дереве процессов, свяжите его в проекции характеристик с соответствующими ему функциями (так же можно установить связь подуровня или надуровня этого процесса).

Вопрос

Как правильно создать набор проекций для процессного описания?

Ответ

Создайте набор проекций. В качестве базового классификатора укажите классификатор "Функции". В качестве классификатора характеристик укажите классификатор "Процессы". В качестве проекции характеристик укажите проекцию, связывающую классификатор "Функции" и классификатор "Процессы" (см. вопрос "Почему в дереве процессов видны не все процессы?"). Затем подключите к процессу проекции. Проверьте, что у каждой подключенной проекции установлен флаг "Использовать характеристики" и указан соответствующий проекции тип связей (отличный от типа "<<>>").

Для описания процесса обычно используются следующие проекции:

Функции_Функции(Документы) – тип связей "Вх/Вых/Упр" – для описания документооборота процесса;

Дополнительно может быть создана проекция Функции_Документы  - тип связей "Упр" – для задания документов, регламентирующих выполнение операций процесса;

Функции_Функции(Ресурсы) – тип связей "Вх/Вых/Исп" – для описания ресурсооборота процесса;

Дополнительно может быть создана проекция Функции_Ресурсы – тип связей "Исп" – для задания основных средств, используемых при выполнении операций процесса;

Функции_Оргзвенья – тип связей "Исп" – для задания исполнителей и владельцев процесса;

Функции_Хранилища документов(Документы) – тип связей "Чт/Зп" – для описания документооборота процесса через электронные и бумажный носители информации (например электронные базы данных); Функции_Хранилища ресурсов(Ресурсы) – тип связей "Чт/Зп" - для описания ресурсооборота процесса через склады и прочие хранилища.

Вопрос

Можно ли в процессе задать условный переход? Например: В процессе осуществляется составление документа, проверка документа, и подпись документа. Если документ составлен правильно, то он передается на подпись, если документ составлен неправильно, то он отправляется на доработку.

Ответ

Условный переход в процессе задайте при помощи расстановки индексов в проекции Функции_Функции(Документы) или в проекции Функции_Функции(Ресурсы). Устанавливайте исходящие связи от функции, которая выполняет проверку условия к функциям, которые будут выполняться после проверки условия. У каждой из этих связей установите в качестве индекса условие, при котором эта функция выполняется. Подробнее:

Выберите проекцию, в которой будете задавать условный переход. Т.к. в вашем примере ведется работа с документом, то условный переход нужно задавать в проекции Функции_Функции(Документы).

Определите функцию, в ходе выполнения которой будет осуществляться проверка условия. В вашем примере – это функция "проверка документа". Убедитесь, что эта функция внесена в классификатор функций.

Кратко сформулируйте условия, которые влияют на то, какая из функций будет выполняться следующей. И добавьте эти условия в классификатор индексов проекции, в которой задается условный переход. Часто используются индексы "условие выполняется" и "условие не выполняется" или "выполняется условие1", "выполняется условие2", "выполняется условие3". В вашем примере дальнейшие действия после проверки документа будут зависеть от того, правильно или неправильно оформлен документ. Значит, можно сформулировать следующие условия: документ "оформлен правильно" и документ "оформлен неправильно". Добавьте строку "оформлен правильно" и строку "оформлен неправильно" в классификатор индексов проекции Функции_Функции(Документы) (о работе с классификатором индексов см. "Руководство пользователя" раздел "Проекции" глава "Установка и удаление связей").

Определите функции, которые будут выполняться далее в зависимости от результата проверки условия. В вашем примере: если документ "оформлен правильно", то следующей будет выполняться функция "подпись документа"; если документ "оформлен неправильно", то документ будет возвращен на доработку, т.е. снова будет выполняться функция "составление документа". Убедитесь, что эти функции внесены в классификатор функций.

Поочередно назначьте исходящие связи от функции, в ходе которой осуществлялась проверка условия к функциям, которые будут выполняться далее. У каждой функции в качестве индекса устанавливайте условие, при котором эта функция выполняется. Эти условия мы добавляли в классификатор индексов в п.3. В вашем примере: От функции " проверка документа " задайте: а) исходящую связь (тип "Вых") к функции "подпись документа" установите у этой связи индекс "оформлен правильно"; в) исходящую связь (тип "Вых") к функции "составление документа" установите у этой связи индекс "оформлен неправильно".

Полученный таким образом условный переход будет отражен как в наборе проекций, так и на диаграмме процесса, полученной в результате работы Мастера диаграмм бизнес-процессов.

Вопрос

В наборе проекций установили для редактирования проекцию "Функции_Функции(Документы)" (или

"Функции_Функции(Ресурсы)"). Почему появляются серые связи, которые в этой проекции не устанавливались? Направления связей "<" и ">".

Ответ

В программе предусмотрена возможность отображать в наборе проекций не только непосредственную взаимосвязь функций в проекциях документооборота ("Функции_Функции(Документы)") и ресурсооборота ("Функции_Функции(Ресурсы)"), но и взаимосвязь функций через хранилища документов (проекция "Функции_Хранилища документов(Документы)") или ресурсов (проекция "Функции_Хранилища ресурсов(Ресурсы)"). Взаимосвязь функций через хранилища отображается в наборах проекций серым цветом, а на диаграмме бизнес-процесса – серыми пунктирными линиями. Связь через хранилище появляется в случае, если в результате выполнения одной из функций произвелась запись в хранилище документов (или в хранилище ресурсов), а в ходе выполнения второй функции произвелось считывание этой информации из хранилища  (например: если в результате выполнения функции произвелась запись строки в таблицу электронной базы данных, а при выполнении другой функции произвелось чтение этой строки из таблицы электронной базы данных, то эти две функции связаны через хранилище). Данную возможность можно подключить или отключить в настройках программы ("Сервис" - "Вид" - "Проекции и наборы" - "Отображать связи через хранилище").

5. Экспорт классификаторов, проекций и результатов работы мастеров в Excel.

Вопрос

При отправке классификатора или проекции в Excel отображается только пустая страница Excel. При формировании в Excel плана-графика мероприятий получается только шапка таблицы.

Ответ

Проверьте в главном меню MS Excel настройки в разделе "Сервис" - "Макрос" - "Безопасность" - "Уровень безопасности". Скорее всего, установлен "Высокий" уровень безопасности, при котором все макрокоманды отключаются автоматически. "Высокий" уровень безопасности обычно устанавливается для защиты программного обеспечения при просмотре файлов Excel, полученных из непроверенных источников (например, полученных по интернету). На время проведения экспорта классификатора или проекции из программы "ОРГ-Мастер Профи" в Excel, должен быть установлен "Средний" уровень безопасности. При экспорте классификатора или проекции в Excel устанавливайте флаг "Не отключать макросы". Также должен быть установлен уровень безопасности "Средний" при экспорте отчетов и результатов работы мастеров в Excel.

Вопрос

При экспорте в Excel планов мероприятий (бюджетных форм) выдается ошибка.

Ответ

Для устранения ошибки установите опцию "Отображать расширения для зарегистрированных типов файлов" в свойствах папки для каталога Modules\excel.

IV.   Вопросы по многопользовательской версии

1. Общие вопросы

Вопрос

Какой компьютер лучше использовать в качестве сервера для "ОРГ-Мастер Профи"?

Ответ

В качестве машины сервера используйте компьютер, постоянно включенный в течение всего рабочего дня (лучше выделенный компьютер).

Вопрос

Пользователи работают с моделями, установленными в локальном режиме. Что делать если сервер, на котором установлен сетевой ключ, "завис"?

Ответ

Если компьютер-сервер завис в процессе работы, перезагрузите его. Работа пользователей, использующих в этот момент сетевой ключ, может быть продолжена после перезагрузки сервера.

Вопрос

При открытии модели с сервера выводится сообщение "Модель заблокирована. Открыть только для чтения?" хотя в этот момент пользователей, работающих с программой нет. Как это исправить?

Ответ

Убедитесь, что на сетевом диске, с которого вы открываете модель, открыт доступ на запись

2. Совместная работа

Вопрос

Как правильно синхронизировать модель на разных ПК (основной и ноутбук, например)?

Ответ

1.Создайте модель на основном рабочем месте. Сохраните эту модель в виде отдельного файла модели (команда "Модель" - "Отправить" - "В директорию"). На втором рабочем месте создайте модель импортом из полученного файла модели (команда "Модель" - "Создать" - "Из файла") 2. После изменений модели сохраняйте ее в виде файла модели, и в другом месте обновляйте модель из этого файла (см. "Руководство пользователя" раздел "Репозитарий моделей" глава "Режим обновления модели").

Вопрос

Как настроить программу для совместной работы нескольких пользователей с одной моделью?

Ответ

1. Создать модель локально у одного из пользователей. 2. Отправить как модель для совместного доступа. 3. В другой папке (чтобы впоследствии не перепутать модели) создать модель из файла (в который отправляли ранее), поставив флажок "Совместный доступ" Повторить пункт 3 для всех пользователей, которые будут работать с этой моделью. Сетевой адрес модели необходимо указывать для всех пользователей одинаково в форме \\server\Путь\Файл_модели.bpj. При работе с различными ОС (98, ME, 2000, XP), сервер, где будут располагаться модели, должен работать под управлением наиболее новой ОС.

Вопрос

Как соединять модели, сделанные независимо разными пользователями?

Ответ

1. Предварительная подготовка для раздельного изменения

Необходимо у одного из пользователей создать эталонную модель, в которой будет осуществляться последующая сборка. Далее следует раздать эталонную модель участникам разработки.

2. Порядок объединения моделей

При объединении нескольких моделей с эталонной вначале необходимо очистить все классификаторы и проекции эталонной модели. При объединении нескольких моделей слияние происходит последовательно. Т.е. сначала 1-я модель полностью объединяется со 2-й, затем результат объединяется с 3-й и.т.д. При объединении двух моделей вначале объединяются все классификаторы, затем в проекции добавляются связи путем импорта. После того, как объединение моделей завершено, разработчикам раздается новая эталонная модель, и процесс повторяется снова. После каждого объединения рекомендуется сохранять эталонную модель в архиве.

3. Слияние классификаторов

3.1. Если пользователи работали в различных частях классификатора

Необходимо открыть классификатор эталонной модели. Загрузить для импорта позиций классификатор пользовательской модели. Выбрать в импортируемом классификаторе добавленные позиции и импортировать их необходимое место.

3.2. Если пользователи меняли одинаковые части

Необходимо открыть классификатор эталонной модели. Загрузить для импорта позиций классификатор пользовательской модели. Выбрать в обоих классификаторах позиции для синхронизации и выполнить команду "Синхронизировать внутренние индексы"\"Обновить Подуровни".

Ждем ваших звонков:
+7 (812) 6703162
191015, Россия, Санкт-Петербург,
Фуражный пер., д.3
© 1999-2017 Бизнес Инжиниринг Групп
Написать письмо в службу поддержки сайта Бизнес Инжиниринг Групп
admin@bigc.ru www.bigc.ru  
  Рейтинг@Mail.ru
Главная Новости Контакты Поиск Персональный раздел
© 2006-2007 Разработка сайта - компания Lenvendo Работает на “1С-Битрикс: Управление сайтом”